Fix WordPress Image Cropping Error on Fedora LAMP Server

While working on a development site this morning that runs on a localhost Fedora 25 LAMP server, I ran into an issue when trying to crop an image within WordPress that returned the message “There has been an error cropping your image”.

It turns out this is a quick and easy thing to fix.  You’ll just need to install the php-gd package on your system.

As root (or using sudo):

dnf install php-gd

Once installed, you’ll need to restart your Apache server.  Again, as root or using sudo:

apachectl restart

Your local Apache server will quietly restart itself.  Now you can head back over to your WordPress backend and crop your images without issue!

Leave a Reply

Your email address will not be published. Required fields are marked *